[Home]Eclipse

Robo Home | Changes | Preferences | AllPages

An open source IDE made by IBM, get it for free at http://www.eclipse.org

Some of the more useful features:

and many more.

The [sourceforge help page] for robocode has a good getting started guide under the "Using Eclipse" section.


KeepResident? for Eclipse (http://suif.stanford.edu/pub/keepresident/keepresident-0.1.0.zip) will prevent the annoying lagginess that sometimes happens when Windows has been a little overenthusiastic in swapping Eclipse out to the hard drive. Windows only. Written by a research group that a friend of mine is a member of. :-) --David Alves

Cool! IŽll take a try for sure! If it ends with those swap-breaks that will be great! -- Axe

This is something I ought to be able to figure out by myself, but I haven't yet. I just got Eclipse and am wondering what the easiest way to compile a bot is. Help? -- Alcatraz

Eclipse automatically compile the files when you save them. You can then set the path to them in robocode->preferences->developpement (IIRC). --Florent

Don't forget to add the robocode.jar file to the external jars in the build path in the project options when you use Eclipse. You get this by right-clicking on the project. I use Eclipse all the time for Java programming and I find code completion the best feature. -- StefW

Thanks. -- Alcatraz

A vi Plugin!

Now Eclipse just got perfect for me: Seriously if you're a vi junkie like me and still find Eclipse bringing you so much power then this plugin enters as the answer to your coding prayers.

-- PEZ

I just managed to download this to my jumpdrive via the school and download.com, took about 1/1000th the time it would of normally taken me. I'll check it out once I get home. --Chase-san

Have you guys figured out how to use the visual debugger yet? I used that all the time. You just have to set up a launch configuration in Eclipse that will start robocode *from* eclipse, and you're good to go. Set a breakpoint, launch it in debug mode, & step through your code line by line seeing the values your bot has for any of its variables. Just make sure to switch the breakpoint from the default "Suspend Thread" to "Suspend VM". --Simonton

For the problems display, is there a known way to only display problems from the project your rooting around in. I find it annoying to have warnings popping up in like my cvs robocode source or my Illustrator source while i'm working on my robots. --Chase-san

What I do is close the other projects (right click on project name / close project). I don't know if there are other ways to do it, but that should work. -- Voidious

Thanks --Chase-san

You can also modify the filter by clicking the little down arrow and selecting "Configure Filters...", then create a filter that has has the "On any element in same project" selected. When you use that filter, problems from other projects will be automatically filtered out when you are working on that project, without having to close other projects. Still, closing the other projects probably frees up memory and speeds things up. --RobertWalker


Ok, i've done everything described in the webpage, and im stuck on the last part. Btw fnl im not sure if it's my comp robocode itself, but when you click 'Finish' on the preferences it just stays there, and you need to click Cancel, which finishes it, except for the development options, which doesn't work. --Starrynte

What is it you're stuck on? What webpage? -- Simonton

Sorry i didn't give more information. Anyways the webpage was http://robocode.sourceforge.net/help/ (it uses frames). How I get 'stuck' is that i did everything described on the webpage, but when i click finish on the development options, the preferences just stay there and robocode doesnt do anything. --Starrynte

Are you, by chance, running this on a client that has been used for the rumble? I wonder if it's not actually stuck, but taking a very long time to refresh the robot database because there are so many robots there. -- Simonton

The preferences freeze even if it's not a development options change ,but in those cases when i click cancel the pref changes happen. its only 4 the development options. and no im not running a rumble client. --Starrynte


So I'm preparing to release and open-source PluggableRobot. It originally lived in its own package in the same project as RabidWombat, so I broke it off into its own project. This appears to cause problems with running RabidWombat now. If I make the PluggableRobot project a required project on RabidWombat's build path, everything compiles, but when I launch the Robocode client I get a bunch of NoClassDefFoundErrors? on classes from PluggableRobot. If I create a JAR for PluggableRobot and include it in RabidWombat as a library, it still compiles, but Robocode still complains. Does anyone have experience with including dependent project or JARs in a bot? How do you make it so Robocode can find it when running a development version? --RobertWalker


So I'm getting a really weird error when I try to debug my robot from eclipse. I'm able to run the game just fine from eclipse, but for some reason, as soon as I start a round with any robots, even the sample, mine with a break point and mine when it doesn't even have break point, it terminates with an exit value of 1. I'm using java jre1.5.0_11 with Robocode version 1.4.5. Error Message:

Preparing battle...
----------------------
Round 1 initializing....
#
# An unexpected error has been detected by HotSpot Virtual Machine:
#
#  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x6d3a217d, pid=4700, tid=2420
#
# Java VM: Java HotSpot(TM) Client VM (1.5.0_11-b03 mixed mode)
# Problematic frame:
# C  [jdwp.dll+0x1217d]
#

Let the games begin!
# An error report file with more information is saved as hs_err_pid4700.log
#
# If you would like to submit a bug report, please visit:
#   http://java.sun.com/webapps/bugreport/crash.jsp
#

And I can't make it look right... oh well, I hope somebody can read it. If somebody wants to read the error log, I could send it to them. -- KID

My Eclipse just has a "timeout" error if you don't Step In right after a breakpoint, and then if you resume, it just freezes up... --Starrynte


Robo Home | Changes | Preferences | AllPages
Edit text of this page | View other revisions
Last edited April 9, 2008 23:27 EST by Starrynte (diff)
Search: