[Home]RoboRumble/Testing

Robo Home | RoboRumble | Changes | Preferences | AllPages


I use XP Pro, and it didn't work:

 C:\robocode>roborumble.bat

 C:\robocode>java -Xmx256M -cp c:\robocode\robots;robocode.jar;roboleague.jar;codesize.jar roborumble.RoboRumbleAtHome? c:/robocode/robots/roborumble/roborumble.txt
 Unable to retrieve participants list
 java.io.FileNotFoundException?: c:\robocode\robots\roborumble\files\particip1v1.txt (The system cannot find the path specified)
 Battles input file not found ... Aborting
 java.io.FileNotFoundException?: c:\robocode\robots\roborumble\files\particip1v1.txt (The system cannot find the path specified)
 Participants file not found ... Aborting
 java.io.FileNotFoundException?: c:\robocode\robots\roborumble\files\particip1v1.txt (The system cannot find the path specified)

I was online at the time. -- Tango

There are two directories that were not included in the ZIP file because they are empty: "temp" and "files". Just create them under "roborumble" directory and it should work. -- Albert


I tested it in Win98 environment and it seems to work fine (after creating temp and files directories). -- Albert


After temp & files I got below error message. I use XP pro with java sdk 1.4.2_01. I also tested with 1.4.1 still the same mistakes. I don't use proxy but I have norton firewall. I tracked it its not the problem. SSO?

E:\java\robocode>java -Xmx256M -cp e:\java\robocode\robots;robocode.jar;roboleague.jar;codesize.jar roborumble
.RoboRumbleAtHome e:/java/robocode/robots/roborumble/roborumble.txt
Wrong file lenght: apv.MicroAspid_1.6.jar
Could not download bot apv.MicroAspid_1.6.jar from
Wrong file lenght: apv.Aspid_1.7.jar
Could not download bot apv.Aspid_1.7.jar from
Wrong file lenght: kawigi.f.FhqwhgadsMicro_1.0.jar
Could not download bot kawigi.f.FhqwhgadsMicro_1.0.jar from
Wrong file lenght: kawigi.nano.FunkyChicken_1.1.jar
Could not download bot kawigi.nano.FunkyChicken_1.1.jar from
Wrong file lenght: kawigi.sbf.Barracuda_1.0.jar
Could not download bot kawigi.sbf.Barracuda_1.0.jar from
Wrong file lenght: kawigi.sbf.FloodHT_0.8.jar
Could not download bot kawigi.sbf.FloodHT_0.8.jar from
Wrong file lenght: kawigi.sbf.FloodMicro_1.5.jar
Could not download bot kawigi.sbf.FloodMicro_1.5.jar from
Wrong file lenght: kawigi.sbf.FloodMini_1.4.jar
Could not download bot kawigi.sbf.FloodMini_1.4.jar from
Wrong file lenght: kawigi.sbf.FloodNano_1.2.jar
Could not download bot kawigi.sbf.FloodNano_1.2.jar from
Wrong file lenght: kawigi.sbf.Teancum_1.3.jar
Could not download bot kawigi.sbf.Teancum_1.3.jar from
Wrong file lenght: wiki.mini.Sedan_1.0.jar
Could not download bot wiki.mini.Sedan_1.0.jar from
Wrong file lenght: dft.Immortal_0.88.jar
Could not download bot dft.Immortal_0.88.jar from

Strange. It is accessing the Wiki but it seems RobocodeRepository is refusing the request. Are you using a proxi? May be java 1.4.2 behaves different from 1.4.1? Could someone else with 1.4.2 make the test?


It worked better than before, but still not great -- Tango:
C:\robocode>java -Xmx256M -cp c:\robocode\robots;robocode.jar;roboleague.jar;codesize.jar roborumble.RoboRumbleAtHome c:/robocode/robots/roborumble/roborumble.txt
Downloaded apv.MicroAspid 1.6 into c:/robocode/robots/apv.MicroAspid_1.6.jar
Downloaded apv.Aspid 1.7 into c:/robocode/robots/apv.Aspid_1.7.jar
Downloaded kawigi.f.FhqwhgadsMicro 1.0 into c:/robocode/robots/kawigi.f.FhqwhgadsMicro_1.0.jar
Downloaded kawigi.nano.FunkyChicken 1.1 into c:/robocode/robots/kawigi.nano.FunkyChicken_1.1.jar
Wrong file lenght: kawigi.sbf.Barracuda_1.0.jar
Could not download bot kawigi.sbf.Barracuda_1.0.jar from
Wrong file lenght: kawigi.sbf.FloodHT_0.8.jar
Could not download bot kawigi.sbf.FloodHT_0.8.jar from
Downloaded kawigi.sbf.FloodMicro 1.5 into c:/robocode/robots/kawigi.sbf.FloodMicro_1.5.jar
Wrong file lenght: kawigi.sbf.FloodMini_1.4.jar
Could not download bot kawigi.sbf.FloodMini_1.4.jar from
Downloaded kawigi.sbf.FloodNano 1.2 into c:/robocode/robots/kawigi.sbf.FloodNano_1.2.jar
Wrong file lenght: kawigi.sbf.Teancum_1.3.jar
Could not download bot kawigi.sbf.Teancum_1.3.jar from
Downloaded wiki.mini.Sedan 1.0 into c:/robocode/robots/wiki.mini.Sedan_1.0.jar
Downloaded dft.Immortal 0.88 into c:/robocode/robots/dft.Immortal_0.88.jar
Fighting... kawigi.f.FhqwhgadsMicro 1.0,dft.Immortal 0.88
Fighting... apv.Aspid 1.7,kawigi.nano.FunkyChicken 1.1
Fighting... kawigi.nano.FunkyChicken 1.1,apv.Aspid 1.7



****************
Another exception has been detected while we were handling last error.
Dumping information about last error:
ERROR REPORT FILE = (N/A)
PC                = 0x6D3C94E8
SIGNAL            = -1073741819
FUNCTION NAME     = (N/A)
OFFSET            = 0xFFFFFFFF
LIBRARY NAME      = (N/A)
Please check ERROR REPORT FILE for further information, if there is any.
Good bye.

Thanks for your help. Could you try again and see if it keeps failing on the same bots? May be the problem is from RobocodeRepository, because it is downloading some bots but not downloading some others. Was the last part ("Another exception...") of RoboRumble? I never programmed something like this. -- Albert

That last error probably is an issue with the JVM you are using. I have had some problems with RoboLeague crashing the JVM on me. -- PEZ

Things seem to work here. I'm using MacOSX which is probably best categorized as a Unix system. I created a shell script (roborumble.sh) for this and had to make some changes to the roborumble.txt file. Here's the shell script:

#!/bin/bash
cd robots
java -Xmx256M -cp .:../robocode.jar:../../roboleague/roboleague.jar:../../roboleague/codesize.jar roborumble.RoboRumbleAtHome roborumble/roborumble.txt
Note that this changes working directory to "robots" first. I use relative paths here. Should probably work in the roborumble.bat file to if you just use semi-colons instead of colons. Here's the patched roborumble.txt file:
#RoboRumble@home properties

#properties for the battle engine

USER=ALBERT
INPUT=roborumble/files/battles1v1.txt
ROUNDS=10
FIELDL=800
FIELDH=600
OUTPUT=roborumble/files/results1v1.txt

#properties to retrieve bots from internet

BOTSREP=.
TEMP=roborumble/temp/

#properties to retrieve participants list from internet

PARTICIPANTSURL=http://robowiki.dyndns.org/?RoboRumble/Participants
PARTICIPANTSFILE=roborumble/files/particip1v1.txt
STARTAG=pre

#properties to prepare the battles list

NUMBATTLES=5
I've just changed the paths to relative ones. This should work for all systems as long as roborumble was started from the "robots" directory. -- PEZ

I'll run it once more, and then i'm going to bed. I'll paste the results here whatever they are. -- Tango

Ok, it's run slightly better, ie. the last error didn't happen this time. I forgot to delete the bots it downloaded last time, so we have no way to tell if it was only failing on certain bots:

C:\robocode>java -Xmx256M -cp c:\robocode\robots;robocode.jar;roboleague.jar;codesize.jar roborumble.RoboRumbleAtHome c:/robocode/robots/roborumble/roborumble.txt
Wrong file lenght: kawigi.sbf.Barracuda_1.0.jar
Could not download bot kawigi.sbf.Barracuda_1.0.jar from
Wrong file lenght: kawigi.sbf.FloodHT_0.8.jar
Could not download bot kawigi.sbf.FloodHT_0.8.jar from
Wrong file lenght: kawigi.sbf.FloodMini_1.4.jar
Could not download bot kawigi.sbf.FloodMini_1.4.jar from
Wrong file lenght: kawigi.sbf.Teancum_1.3.jar
Could not download bot kawigi.sbf.Teancum_1.3.jar from
Fighting... apv.MicroAspid 1.6,kawigi.nano.FunkyChicken 1.1
Fighting... kawigi.sbf.FloodMicro 1.5,kawigi.f.FhqwhgadsMicro 1.0
Fighting... apv.Aspid 1.7,wiki.mini.Sedan 1.0
Fighting... wiki.mini.Sedan 1.0,apv.Aspid 1.7
Fighting... wiki.mini.Sedan 1.0,apv.MicroAspid 1.6

I'll go delete them and try once more. -- Tango

It's the same bots failing each time. I'll leave you all to work out why, i'm going to bed. BTW, someone might want to make /Testing and move all this stuff over there... there's a lot of it.

C:\robocode>java -Xmx256M -cp c:\robocode\robots;robocode.jar;roboleague.jar;codesize.jar roborumble.RoboRumbleAtHome c:/robocode/robots/roborumble/roborumble.txt
Downloaded apv.MicroAspid 1.6 into c:/robocode/robots/apv.MicroAspid_1.6.jar
Downloaded apv.Aspid 1.7 into c:/robocode/robots/apv.Aspid_1.7.jar
Downloaded kawigi.f.FhqwhgadsMicro 1.0 into c:/robocode/robots/kawigi.f.FhqwhgadsMicro_1.0.jar
Downloaded kawigi.nano.FunkyChicken 1.1 into c:/robocode/robots/kawigi.nano.FunkyChicken_1.1.jar
Wrong file lenght: kawigi.sbf.Barracuda_1.0.jar
Could not download bot kawigi.sbf.Barracuda_1.0.jar from
Wrong file lenght: kawigi.sbf.FloodHT_0.8.jar
Could not download bot kawigi.sbf.FloodHT_0.8.jar from
Downloaded kawigi.sbf.FloodMicro 1.5 into c:/robocode/robots/kawigi.sbf.FloodMicro_1.5.jar
Wrong file lenght: kawigi.sbf.FloodMini_1.4.jar
Could not download bot kawigi.sbf.FloodMini_1.4.jar from
Downloaded kawigi.sbf.FloodNano 1.2 into c:/robocode/robots/kawigi.sbf.FloodNano_1.2.jar
Wrong file lenght: kawigi.sbf.Teancum_1.3.jar
Could not download bot kawigi.sbf.Teancum_1.3.jar from
Downloaded wiki.mini.Sedan 1.0 into c:/robocode/robots/wiki.mini.Sedan_1.0.jar
Downloaded dft.Immortal 0.88 into c:/robocode/robots/dft.Immortal_0.88.jar
Fighting... kawigi.sbf.FloodNano 1.2,kawigi.nano.FunkyChicken 1.1
Fighting... apv.Aspid 1.7,kawigi.sbf.FloodNano 1.2
Fighting... apv.MicroAspid 1.6,kawigi.nano.FunkyChicken 1.1
Fighting... apv.MicroAspid 1.6,kawigi.nano.FunkyChicken 1.1
Fighting... kawigi.nano.FunkyChicken 1.1,apv.Aspid 1.7

Goodnight all. -- Tango


It seems it's failing to download the big bots (jar files with more than 50K) even if it downloaded Aspid correctly (and it's 122K). May be the connection is timming out while it reads? Are you using ADSL, cable or modem? I'w try to change it a little bit to avoid it and make some tests. -- Albert
I have a 56k modem. I'm assuming "lenght" is a typo for "length", yes? If it was large jars then it wouldn't get aspid, and i wouldn't expect SSO? to fail on all of them. -- Tango

For version 2 testing see /testing2? -- Tango


Robo Home | RoboRumble | Changes | Preferences | AllPages
Edit text of this page | View other revisions
Last edited August 28, 2003 11:15 EST by Tango (diff)
Search: